Logwatch installation – cPanel with CentOS 6 (64bit)

Posted by: Chris  :  Category: Linux Tips

By default, Logwatch is not installed on a CentOS 6 (x64) server (not sure about 32bit versions..?). This is something that I have missed from using the previous versions of CentOS. As a server admin, I like to be able to review this file to see if anything funny or strange has happened over the past day. When trying to install this from yum, I was getting an error:

Error: Package: logwatch-7.3.6-49.el6.noarch
Requires: perl(Date::Manip)

Installing perl(Date::Manip) through the cPanel perl modules interface did not cure the issue. The perl version required by Logwatch is newer than the default cPanel version.

Here is how I corrected the issue and was able to get Logwatch working properly….
Read more…